KB159: Agents get stuck in an idle state in 5.1 SP2

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KB159: Agents get stuck in an idle state in 5.1 SP2



Symptoms:

After installing 5.1 SP2 some agents are showing up as Idle even though they are taking calls and inspectors show ACD data being collected for them.

Cause:

A bug was introduced in 5.1 SP2 in regards to agents where we don't get the extension on the first record, so we end up having to create a Ghost extn to store state until we get the actual extension. An example would be an agent who works over midnight and the next day the first record we get for them is ringing or answer acd. Problem arises when we swap the state with the extension we got from the stream we didn't copy over all of the state and this would cause some problems in the future(when they log off and another agent logs in to that extn).

 

Resolution:

 

The fix involves a deep copy of the state between the extn's to preserve all of the data upon the swap. Also logging was added to show when the swap's are happening so we can account for these cases.

Apply the attached hotfix to the customers box, look at realtime for the agent that was in question as well you will have to summarize for any days that they were running 5.1 SP2 to be safe.

 

Testcase

 

Ensure that there are no records for the current day for any of the agents involved in the test. Turn off processing of ringing records as well.

 

Agent1 Ringing P100
Agent1 AnswerACD P100
Agent1 Hold (extn1)
Agent1 Retreive Hold(extn1)
Agent1 Worktimer (extn1)
Agent1 Remove Worktimer (extn1)

Agent1 Logout (extn1)

 

Agent2 Login (extn1)
Agent2 Ringing P100
Agent2 AnswerACD P100 (problem starts here, in 5.1 SP2 agent will stay idle)
Agent2 Hold (extn1)
Agent2 Retreive Hold(extn1)
Agent2 Worktimer (extn1)
Agent2 Remove Worktimer (extn1)
Agent2 Logout (extn1)

 

Agent2 Ringing P200
Agent2 Ringing P100
Agent2 AnswerACD P100
Agent2 Hold (extn1)
Agent2 Retreive Hold(extn1)
Agent2 Worktimer (extn1)
Agent2 Remove Worktimer (extn1)
Agent2 Logout (extn1)

 

How to apply this fix:

This hotfix must be installed on your Enterprise Server and you must be running version 5.1 SP2
Download the hotfix to your server from here: KB159
Download the hotfix to your server from here:
Double click the .exe file and follow the instructions

 



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Details
Last Modified:Thursday, January 13, 2011
Last Modified By: kmiddlemiss
Type: HOTFIX
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