Article ID: 50326 - Last Review: October 2, 2013
PROBLEM
Telephone System Synchronization fails with error "Code:[MimaRCGeneralFailure] Error:[General failure. Unable to complete the operation.]"
CAUSE
This issue has been seen when the PBX and Enterprise Server are not on the same subnet. The extra routing or network security can cause issues with telephone system synchronization completing.
WORKAROUND
There are two possible workarounds for this issue:
1. Put the PBX and Enterprise Server on the same subnet.
2. Set the PBX to perform a DirectToPbx synchronization.
Stop the Data Synchronization service and the open the file prairieFyre.Services.DataSynchronizationService.exe.config from C:\Program Files\prairieFyre Software Inc\CCM\Services\DataSynchronizationService and set the value for DirectToPbx to true.
Stop the Configuration service and open the file ConfigService.exe.config from C:\Program Files\prairieFyre Software Inc\CCM\Services\ConfigService and set the value for DirectToPbx to true.
<add key="LoggingLevel" value ="4"/>
<add key="MixmlServerPort" value="18000"/>
<add key="DirectToPbx" value="true"/>
NOTE: For CCM versions 5.6 GA and later, the config file is a little different and will look like the following:
<setting name="DirectToPbx" serializeAs="String">
<value>True</value>
</setting>
<setting name="MixmlServicePort" serializeAs="String">
<value>18000</value>
</setting>
Once these configuration changes are made you will need to restart the Configuration service, and ensure that Data Sync restarts (if it is already stopped no action is necessary).
Keywords:direct to pbx