KB27022: Collector restarts with reported OS exception

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KB27022: Collector restarts with reported OS exception


Problem

Under a heavy load with a lot of MiTAI monitors set on a single PBX, the Collector will sometimes automatically restart itself.



Symptoms

In the Collector log, you see the following similar errors:
eError: 7/4/2009 3:52:32 AM MiTAIEngine - SetExtnMonCallback: Failed to monitor device - DN:[14386] ReturnCode:[PF_MITAI_HAD_OS_EXCEPTION] Hmon:[0]
eError: 7/4/2009 3:52:32 AM MiTAIEngine - SetExtnMonCallback: Failed to monitor device - DN:[14389] ReturnCode:[PF_MITAI_HAD_OS_EXCEPTION] Hmon:[0]
eError: 7/4/2009 3:52:32 AM MiTAIEngine - SetExtnMonCallback: Failed to monitor device - DN:[14542] ReturnCode:[PF_MITAI_HAD_OS_EXCEPTION] Hmon:[0]
eError: 7/4/2009 3:52:33 AM MiTAIEngine - SetExtnMonCallback: Failed to monitor device - DN:[95898] ReturnCode:[PF_MITAI_HAD_OS_EXCEPTION] Hmon:[0]



Cause

A particular library occasionally provided us with faulty data that we weren't expecting, causing a memory access violation when we tried to use it.



Workaround

Reduce the number of active MiTAI monitors from YourSite Explorer.
Select an Agent or Extension and set it to Real time and reporting instead of Advanced real time and reporting.



WARNING: MiTAI monitors are required for such things as Interactive control, displaying caller ID, PhoneSet Manager, screen pop etc.



Resolution

This hotfix has been included in all subsequent software versions.  For our latest software and updates, please go to www.mitel.com .

If you have a business need for this hotfix and are unable to update to a supported software version, please contact Customer Support for assistance.

Applies To

CCM version 5.5 SP3





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Details
Last Modified:Friday, April 05, 2013
Last Modified By: amontpetit
Type: HOTFIX
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