KB24634: Double screen pops occur intermittently

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KB24634: Double screen pops occur intermittently


Problem

When screen pop is enabled, an agent will occasionally receive two separate screen pops.  The first one is empty while the second one has the collected digit information.



Symptoms

Two screen pops are displayed with an incoming call.  The first one is blank while the second one has the correct information.



Cause

This is caused by a logic error in the code.



Workaround

None.



Resolution

Download the following hotfix to the CCM Enterprise Server: KB24634
Double-click the .exe file and follow the instructions.

Open the CCC config file with Notepad located in the following folder:
C:\Program Files\prairieFyre Software Inc\CCM\Applications\ContactCenterClient\PrairieFyreClientShell.exe.config

Insert the following key under the LoggingLevel key in the appSettings:
<add key="WebPopRequires" value="PFVERIFIEDCOLLECTEDDIGITS" />

Below is a sample of how the config file should look after the change is made:
<appSettings>
<!-- Overrides these will be defaulted as the values regardless of what is in the registry
Simply Uncomment out these lines and enter in the values -->
<!--
<add key="EnterpriseIPAddress" value="10.1.1.1" />
<add key="SSL" value="true" />
-->
<add key="primaryProfileProvider" value="ProfileProvider" />
<add key="AppName" value="ClientShell" />
<add key="loadLastLoadedProfileOnStartUp" value="false" />
<add key="loadProfileOnStartUp" value="false" />
<add key="LoggingLevel" value="3" />
<add key="WebPopRequires" value="PFVERIFIEDCOLLECTEDDIGITS" />
<add key="SubscriptionExpiryMins" value="1440" />

<add key="PortRangeMin" value="5000" />
<add key="PortRangeMax" value="5100" />

When this key is enabled, it will only display the screen pop if the client details message recieved for the call contains a collected digit.


WARNING: Installing the hotfix will Stop and Start ALL prairieFyre services.
It is recommended to install the hotfix outside of regular business hours to avoid any potential service affecting issues.



Applies To

CCM v5.5 SP1





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Details
Last Modified:Sunday, January 23, 2011
Last Modified By: kmiddlemiss
Type: HOTFIX
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