KB29597: Agent showing the wrong state in real-time (5.5 SP1)

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KB29597: Agent showing the wrong state in real-time (5.5 SP1)


Problem

A hotdesking agent with multiple lines has an ACD call routed to a secondary line. When that call ends, the agent goes into worktimer, but when the worktimer ends the agent state continues to show ACD.



Symptoms

In the CCC Agent State by Time real-time monitor an agent is show as being on an ACD call when the agent is actually on Idle or another state. This issue could happen to an agent who has 2 lines and is making/receiving calls on both lines.



Cause

The worktimer record for the end of the call always shows line 0, even if the worktimer actually relates to a secondary line.



Workaround

Have the agent make a call using the secondary line, then hang up.



Resolution

Download the following hotfix to the CCM Enterprise Server: KB29597
Double-click the .exe file and follow the instructions.

WARNING: Installing the hotfix will Stop and Start ALL prairieFyre services.
It is recommended to install the hotfix outside of regular business hours to avoid any potential service affecting issues.



Applies To

CCM v5.5 SP1





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Details
Last Modified:Sunday, January 23, 2011
Last Modified By: kmiddlemiss
Type: HOTFIX
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