KB36810: Unable to load a CCC profile - Exception loading task...

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KB36810: Unable to load a CCC profile - Exception loading task AgentShiftTask


Article ID: 50911 - Last Review: August 24, 2010

PROBLEM

You are unable to load a Contact Center Client profile and an exception is thrown.



SYMPTOMS

The following error can be found in the PFShell log:

eError 8/10/2010 9:31:00 AM Exception loading task AgentShiftTask : e59deea9-bce5-4bac-b826-447df7c418cd
--- Start Exception Stack ---
Microsoft.ApplicationBlocks.UIProcess.UIPException: Can not activate the view AgentShiftMonitor.The original exception is: An entry with the same key already exists. at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource) ---> System.ArgumentException: An entry with the same key already exists.
at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
at System.Collections.Generic.SortedList`2.Add(TKey key, TValue value)
at prairieFyre.WinForms.Monitors.GridExtender.Init() in e:\TeamBuild\CCS\CI_ContactCenterClient_5.7\Sources\Source\Applications\ContactCenterClient\PrairieFyreClientShell\Winforms\Monitors\GridExtender.cs:line 299
at prairieFyre.WinForms.Monitors.GridExtender..ctor(GridControl grid, String[] fixedColumns, XceedGridMonitorState state) in e:\TeamBuild\CCS\CI_ContactCenterClient_5.7\Sources\Source\Applications\ContactCenterClient\PrairieFyreClientShell\Winforms\Monitors\GridExtender.cs:line 70
at prairieFyre.WinForms.Monitors.Monitor_AgentShift.loadMonitorPropertiesFromState() in e:\TeamBuild\CCS\CI_ContactCenterClient_5.7\Sources\Source\Applications\ContactCenterClient\PrairieFyreClientShell\Winforms\Monitors\Monitor_AgentShift.cs:line 1638
at prairieFyre.WinForms.Monitors.Monitor_AgentShift.Initialize(TaskArgumentsHolder args, ViewSettings settings) in e:\TeamBuild\CCS\CI_ContactCenterClient_5.7\Sources\Source\Applications\ContactCenterClient\PrairieFyreClientShell\Winforms\Monitors\Monitor_AgentShift.cs:line 1417
at Microsoft.ApplicationBlocks.UIProcess.WindowsFormViewManager.ActivateForm(WindowsFormView winFormView, ViewSettings viewSettings, Navigator navigator, Guid taskId, String previousView, TaskArgumentsHolder args, Boolean alreadyInitialised)
at Microsoft.ApplicationBlocks.UIProcess.WindowsFormViewManager.CreateNewView(String viewName, Navigator navigator, Guid taskId, TaskArgumentsHolder args)
at Microsoft.ApplicationBlocks.UIProcess.WindowsFormViewManager.ActivateView(String previousView, String view, Navigator navigator, TaskArgumentsHolder args)
at Microsoft.ApplicationBlocks.UIProcess.GraphNavigator.StartMDITask(TaskArgumentsHolder holder, TaskArgumentsHolder args)
--- End of inner exception stack trace ---
at Microsoft.ApplicationBlocks.UIProcess.GraphNavigator.StartMDITask(TaskArgumentsHolder holder, TaskArgumentsHolder args)
at Microsoft.ApplicationBlocks.UIProcess.GraphNavigator.StartMDITask(Guid taskId, TaskArgumentsHolder args)
at Microsoft.ApplicationBlocks.UIProcess.UIPManager.StartNavigationTask(String navGraph, Guid taskId, TaskArgumentsHolder args)
at prairieFyre.WinForm_Applications.ClientShell.ShellController.RestartTask(Guid taskId, String navGraph) in e:\TeamBuild\CCS\CI_ContactCenterClient_5.7\Sources\Source\Applications\ContactCenterClient\PrairieFyreClientShell\ShellController.cs:line 660
at prairieFyre.WinForm_Applications.ClientShell.PrairieFyreClientShellForm.InitViewsMethod(ArrayList activeTasks) in e:\TeamBuild\CCS\CI_ContactCenterClient_5.7\Sources\Source\Applications\ContactCenterClient\PrairieFyreClientShell\PrairieFyreClientShellForm.cs:line 2865--- End Exception Stack ---


CAUSE

The problem is caused by index corruption on the Inbound/Outbound score columns in an Agent Shift Monitor.



WORKAROUND

Rebuild the Contact Center Client profile.



RESOLUTION

This hotfix, along with all other CCM version 5.7 sp1 hotfixes created before January 2010, have been rolled up into one single hotfix.
The 5.7 sp1 Rollup of Hotfixes is available at the following link: KB41351

The original hotfix for this specific issue is no longer available and you must install the rollup.



APPLIES TO

CCM version 5.7 SP1

Keywords: 36810 ccc profile exception cannot load





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Details
Last Modified:Friday, January 21, 2011
Last Modified By: kmiddlemiss
Type: HOTFIX
Article not rated yet.
Article has been viewed 8,357 times.
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