KB39388: There was an error loading a monitor in the profile /...

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KB39388: There was an error loading a monitor in the profile / Queue Now monitor will not display


Article ID: 50952 - Last Review: April 4, 2013

PROBLEM

You receive an Unable to load profile error in the Contact Center Client and the Queue Now monitor will not display.



SYMPTOMS

When loading a CCC profile that contains a Queue Now monitor, the following error occurs:
"There was an error loading a monitor in the profile. Would you like to continue attempting to load the profile?"

The user selects YES to continue, then gets the following error:
"Object reference not set to an instance of an object"
pf.winforms.monitors.monitorbase.resetrowvisibility(DataRow aRow,String aPkeyColumnName) MonitorBase.cs:Line 596, another of the same at line 1851


When trying to add the Queue Now monitor back into the profile, no Queue Groups are available in the add/remove devices screen, just Queues.



CAUSE

The user logging in has security rights to see the profile and the queue but does not have rights to see all the agent groups.  Historical agent groups are invisible to the CCC but the grid is trying to display them.



WORKAROUND

  1. Modify the security list for the users so they can see all the agent groups.
  2. Mark the agent group as real time or remove it from the queue. 
  3. Modify the profile to not have that Queue Now monitor.


RESOLUTION

This hotfix has been included in all subsequent software versions.  For our latest software and updates, please go to www.mitel.com .

If you have a business need for this hotfix and are unable to update to a supported software version, please contact Customer Support for assistance.


 

APPLIES TO

CCM version 5.7 SP1

Keywords: 39388



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Details
Last Modified:Friday, April 05, 2013
Last Modified By: amontpetit
Type: HOTFIX
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