KB40492: IQ 6160 login errors and ports going out of service

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KB40492: IQ 6160 login errors and ports going out of service


Article ID: 51015 - Last Review: April 4, 2013

Problem

Frequently saving changes in IQ or CCM causes IQ login issues and ports going out of service. This occurs when large amounts of Intelligent Queue data exist (such as Interactive Trees).



Symptoms

The following error may be seen when attempting to login to the 6160 UI:


The following error may be seen when attempting to login to the CCMWeb:

Server Error in '/CCMWeb' Application.
--------------------------------------------------------------------------------

Type: System.ServiceModel.CommunicationException
Message: The socket connection was aborted. This could be caused by an error processing your message or a receive timeout being exceeded by the remote host, or an underlying network resource issue. Local socket timeout was '00:30:00'.
Source: mscorlib
Stack:
Server stack trace:
at System.ServiceModel.Channels.SocketConnection.Write(Byte[] buffer, Int32 offset, Int32 size, Boolean immediate, TimeSpan timeout)
at System.ServiceModel.Channels.BufferedConnection.WriteNow(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout, BufferManager bufferManager)
at System.ServiceModel.Channels.BufferedConnection.Write(Byte[] buffer, Int32 offset, Int32 size, Boolean immediate, TimeSpan timeout)
at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.SendPreamble(IConnection connection, ArraySegment`1 preamble, TimeoutHelper& timeoutHelper)
at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.DuplexConnectionPoolHelper.AcceptPooledConnection(IConnection connection, TimeoutHelper& timeoutHelper)
at System.ServiceModel.Channels.ConnectionPoolHelper.EstablishConnection(TimeSpan timeout)
at System.ServiceModel.Channels.ClientFramingDuplexSessionChannel.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Channels.LayeredChannel`1.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.OnOpen(TimeSpan timeout)
at System.ServiceModel.Channels.CommunicationObject.Open(TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.CallOpenOnce.System.ServiceModel.Channels.ServiceChannel.ICallOnce.Call(ServiceChannel channel, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.CallOnceManager.CallOnce(TimeSpan timeout, CallOnceManager cascade)
at System.ServiceModel.Channels.ServiceChannel.EnsureOpened(TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)


6160 ports may go out of service and the following error would be seen in the MessagingEngine log:

eError: 8/17/2010 12:04:45 AM [8008] - Warning: Port went Out of Service, it will not function correctly. Cause: [DeviceOutOfService] (MiTAIPort - ProcessCallEvent)



Cause

When IQ is being saved often, it calls GetIQDataRequest on the CCM server too frequently. When CCM is being saved, IQ calls GetQueueDataRequest on the CCM server to update itself. It calls it potentially twice per service. The problem is more apparent on systems with larger databases and multiple IQ servers.



Workaround

Avoid saving IQ changes during business hours.



Resolution

This hotfix has been included in all subsequent software versions.  For our latest software and updates, please go to www.mitel.com .

If you have a business need for this hotfix and are unable to update to a supported software version, please contact Customer Support for assistance.



Applies To

IQ version 5.7 SP1

NOTE: Click the following link for a list of ALL version 5.7 SP1 hotfixes: KnowledgebaseArticle50959

Keywords: 40492





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Details
Last Modified:Friday, April 05, 2013
Last Modified By: amontpetit
Type: HOTFIX
Article not rated yet.
Article has been viewed 5,378 times.
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