KB38788: The SalesForce connector does not support hot desking...

Expand / Collapse
 

KB38788: The SalesForce connector does not support hot desking agents


Article ID: 51043 - Last Review: November 24, 2010

PROBLEM

The current SalesForce connector does not support hot desking agents, it only supports traditional agents. This hotfix will allow support for Hot Desking Agents.



CAUSE

Hot Desking agents were never originally supported.



WORKAROUND

None.



OTHER INFORMATION

The following additions have also been included in this hotfix along with hot desking agent support:

  • A call log cannot be associated to a popped entity during a warm transfer, because internal calls are not logged. Adding logging capabilities for internal calls should fix that problem and offer a new kind of reporting capability for all SFDC customers.
  • Customer needs to be able to create a "new lead" record at any time during a call to track their campaigns. This new lead needs to have its standard phone field filled with the Caller ID (inbound) or Dialed number (outbound) coming from our connector. It also needs to have one of its custom fields (created by the customer) to be filled with the DNIS coming from our connector during inbound calls. The solution is to present a "New Lead" button in the softphone, and when that "New Lead" button is clicked, it would pop a configurable "new lead" SFDC URL (it would have to be configurable because of the presence of the custom field created by the customer to store the DNIS information).
  • Finally, the way we get YourSite updates in the connector has been upgraded. We currently rely on the 5.5 framework (still in 5.7 to maintain backward compatibility), which is inefficient and slows down the network and the client's response. This is especially important for this customer who has large datasets.


RESOLUTION

This hotfix, along with all other CCM version 5.7 sp1 hotfixes created before January 2010, have been rolled up into one single hotfix.
The 5.7 sp1 Rollup of Hotfixes is available at the following link: KB41351

The original hotfix for this specific issue is no longer available and you must install the rollup.

NOTE: The original hotfix KB38788 replaced KB36432.



APPLIES TO

CCM version 5.7 SP1

Keywords: 36432 38788 salesforce.com sfdc hotdesking agent support added



Rate this Article:
     
Tags:

Add Your Comments


Name: *
Email Address:
Web Address:
Verification Code:
*
 

Details
Last Modified:Monday, January 03, 2011
Last Modified By: ademski
Type: HOTFIX
Rated 1 star based on 1 vote
Article has been viewed 3,015 times.
Options