KB40561: CCC Object reference error when updating Agent Shift...

Expand / Collapse
 

KB40561: CCC Object reference error when updating Agent Shift Monitor with configuration change


Article ID: 51045 - Last Review: April 4, 2013

PROBLEM

A Contact Center Client Object reference error is thrown when updating the Agent Shift Monitor on a database configuration change.



SYMPTOMS

When a user restricted with a security role logs into the Contact Center Client and opens an Agent Shift monitor, if an administrator saves a configuration change in the CCMWeb, all of the Agents will drop from the Agent Shift monitor and an Object reference error will be produced.

This behaviour only seems to happen when a restricted user is logged into the Contact Center Client.



CAUSE

The Contact Center Client is receiving presence events from the enterprise server for agents that it cannot see, probably for security reasons.



WORKAROUND

None.



RESOLUTION

This hotfix has been included in all subsequent software versions.  For our latest software and updates, please go to www.mitel.com .

If you have a business need for this hotfix and are unable to update to a supported software version, please contact Customer Support for assistance.

APPLIES TO

CCM version 5.7 SP1

Keywords: 40561



Rate this Article:
     
Tags:

Add Your Comments


Name: *
Email Address:
Web Address:
Verification Code:
*
 

Details
Last Modified:Friday, April 05, 2013
Last Modified By: amontpetit
Type: HOTFIX
Article not rated yet.
Article has been viewed 4,604 times.
Options