IVR - CCC shows that the Enterprise Server is offline

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IVR - CCC shows that the Enterprise Server is offline


Article ID: 51458 - Last Review: , November 19, 2013

PROBLEM

Enterprise Server service restarting after restoring configuration on new server


SYMPTOMS

The .NET Enterprise Server service restarting frequently.

The Enterprise Server log shows:

Error     4/2/2012 3:55:30 PM      prairieFyre.EnterpriseServices.Client.Authentication          Login error!  Reached the following endpoints:and received this exception: System.Exception: System.ServiceModel.EndpointNotFoundExceptionCould not connect to net.tcp://10.4.0.80:7003/SecurityService. The connection attempt lasted for a time span of 00:00:01.0156250. TCP error code 10061: No connection could be made because the target machine actively refused it 10.4.0.80:7003. 

All VWM Service logs show: 

The description for Event ID 0 from source IvrUpiqService cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.


CAUSE

When restoring an existing backup configuration to a new server the IVR/VWM Media Server remains associated to the old computer name instead of correctly adjusting to the new server name.


WORK AROUND

The computer name associated to the VWM media server can be manually corrected in SQL.

1. Launch SQL Management Studio
2. Open Databases, CCMData, Tables, and find table: dbo.tblEnterprise_Computer
3. Right-click and Edit top 200 rows
4. Highlight and Copy (CTRL C works) the PKey from the correct computer name
5. Open Databases, CCMData, Tables, and find table: dbo.tblEnterpriseConfig_Node
6. Right-click and Edit top 200 rows
7. Paste (CTRL V) into the FKComputerName field for the VWM Media Server to correct the current computer name
8. While in the tblEnterpriseConfig_Node table, verify the IP address for each node.
    NOTE: The IP address for the IVR Node should be the IVR Server where the ports reside.
9. Close SQL Management Studio, and reboot the server.



RESOLUTION

Issue is being addressed in 6.1


APPLIES TO

6.0


Keywords:
IVR VWM service 6.0 Visual Workflow Manager Enterprise



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Details
Last Modified:Tuesday, November 19, 2013
Last Modified By: andrew_montpetit
Type: BUG
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