Pre-Requisite Software Compatibility by MiCC Version

Expand / Collapse
 

Pre-Requisite Software Compatibility by MiCC Version


Article ID: 51491 - Last Review: , January 4, 2021

INFORMATION

The following tables show what versions of .NET, IE, SQL, Windows (Server), and Windows (Client) are supported by version of prairieFyre software.  Please note that a * indicates that it is only partially supported and you should check the System Engineering Guide for more details.  In cases where the table shows Yes SP# this means that it is supported, and has been tested additionally up to the SP# as well.  When in doubt, always check your System Engineering Guide for more detail.

.NET Framework

  6.0.X.X  7.0.X.X 7.1.X.X 8.0.0.0 8.1.0.0 8.1.2.0 9.0.0.0 9.0.1.0 9.0.2.0 9.1.0.0 9.1.1.0 9.1.2.0 9.1.3.0 9.2.0.0 9.2.1.0 9.2.2.0 9.2.3.0 9.3.0.0 9.3.1.0
3.5 SP1   Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes
4.0   Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes
4.5  Yes*  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes
4.6  No  No  No  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes

Internet Explorer
  6.0.X.X  7.0.X.X 7.1.X.X 8.0.0.0 8.1.0.0 8.1.2.0 9.0.0.0 9.0.1.0 9.0.2.0 9.1.0.0 9.1.1.0 9.1.2.0 9.1.3.0 9.2.0.0 9.2.1.0 9.2.2.0 9.2.3.0 9.3.0.0 9.3.1.0
IE 6   Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
IE 7   Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
IE 8   Yes  Yes  Yes (up to 7.1.0.1 only)  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
IE 9   Yes  Yes  Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
IE 10  Yes*  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  No  No  No  No  No  No  No  No
IE 11  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes Yes Yes Yes Yes
Edge  No  No  No  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes Yes Yes Yes Yes

 

NOTE: With MiCC Version 7.1 and newer we recommend using IE10 or newer.  Older versions will work for the most part, but some controls are affected.  An example of this is the manual EMail Address field under report distribution being a non-editable field.  For sites using Multimedia or the Ignite client we recommend IE11 for best performance and compatibility.

SQL Server

  6.0.0.X  6.0.1.X 7.0.X.X 7.1.X.X 8.0.0.0 8.1.0.0 8.1.2.0 9.0.0.0 9.0.1.0 9.0.2.0 9.1.0.0 9.1.1.0 9.1.2.0 9.1.3.0 9.2.0.0 9.2.1.0 9.2.2.0 9.2.3.0 9.3.0.0 9.3.1.0
2005 Express   Yes  Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
2008 Express   Yes  Yes  Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
2008 Express R2   Yes  Yes  Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
2005 SP3  Yes SP4  Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
2008 SP1  Yes  Yes  Yes  Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
2008 R2   Yes SP1  Yes  Yes  Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
2012 Express  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  No  No  No  No  No  No  No  No  No  No
2012  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  No  No  No  No  No  No  No  No  No  No
2014 Express  No  No  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes
2014  No  No  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes
2016  No  No  No  No  No  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes
2016 Express  No  No  No  No  No  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes
2017  No  No  No  No  No  No  No  No  No  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes
2017 Express  No  No  No  No  No  No  No  No  No  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes
2019  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  Yes  Yes  Yes  Yes  Yes
2019 Express  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  Yes  Yes  Yes  Yes  Yes

Excel
  6.0.X.X  7.0.X.X 7.1.X.X 8.0.0.0 8.1.0.0 8.1.2.0 9.0.0.0 9.0.1.0 9.0.2.0 9.1.0.0 9.1.1.0 9.1.2.0 9.1.3.0 9.2.0.0 9.2.1.0 9.2.2.0 9.2.3.0 9.3.0.0 9.3.1.0
2003 SP2  Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
2007 SP2  Yes  Yes  Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
2010   Yes  Yes  Yes  Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes
2013  No  Yes  Yes  Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes
2016  No  No  No  No Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes

Windows on the Server
  6.0.0.X  6.0.2.X 7.0.X.X 7.1.X.X 8.0.0.0 8.1.0.0 8.1.2.0 9.0.0.0 9.0.1.0 9.0.2.0 9.1.0.0 9.1.1.0 9.1.2.0 9.1.3.0 9.2.0.0 9.2.1.0 9.2.2.0 9.2.3.0 9.3.0.0 9.3.1.0
XP Pro SP3   No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
2003 R2 (32-bit)  Yes Sp2  Yes Sp2  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
2008 SP2 (32-bit)  Yes  Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
2008 R2 (64-bit)  Yes  Yes  Yes  Yes  Yes  Yes*  Yes*  Yes*  Yes* Yes*  No  No  No  No  No  No  No  No  No  No
Windows 7 32-bit  Yes*  Yes*  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
Windows 7 64-bit  Yes*  Yes*  Yes*  Yes*  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
Small Business 2011   Yes  Yes*  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
Windows 2012  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes
Windows 2012 R2  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes
Windows 8 32-bit  No  Yes*  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
Windows 8 64-bit  No  Yes*  Yes*  Yes*  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
Windows 8.1 64-bit  No  No  Yes*  Yes*  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
Windows 8.1 32-bit  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
Server 2016  No  No  No  No  No  No  Yes  Yes  Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes Yes
Server 2019  No  No  No  No  No  No  No  No  No  No  No Yes Yes Yes Yes Yes Yes Yes Yes Yes

Windows on the Client

  6.0.0.X  6.0.2.X 7.0.X.X 7.1.X.X 7.1.3.3 8.0.0.0 8.1.0.0 8.1.2.0 9.0.0.0 9.0.1.0 9.0.2.0 9.1.0.0 9.1.1.0 9.1.2.0 9.1.3.0 9.2.0.0 9.2.1.0 9.2.2.0 9.2.3.0 9.3.0.0 9.3.1.0
XP Pro   Yes  Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
Vista 32-bit   Yes  Yes  Yes  Yes  Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
Vista 64-bit   Yes  Yes  Yes  Yes  Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
Windows 7 32-bit   Yes  Yes  Yes  Yes  Yes  Yes  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  No  No  No  No  No
Windows 7 64-bit   Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  No  No  No  No  No
Windows 8 32-bit  No  Yes  Yes  Yes  Yes  Yes  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*
Windows 8 64-bit  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes
Windows 8.1 32-bit  No  No  Yes  Yes  Yes  Yes  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*  Yes*
Windows 8.1 64-bit  No  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes
Windows 10  No  No  No  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes


PBX Compatibility

  6.0.X.X  7.0.X.X 7.1.X.X 8.0.0.0 8.1.0.0 8.1.2.0 8.1.3.0 8.1.4.0 9.0.0.0 9.0.1.0 9.0.2.0 9.1.0.0 9.1.1.0 9.1.2.0 9.1.3.0 9.2.0.0 9.2.1.0 8.2.2.0 9.2.3.0 9.3.0.0 9.3.1.0
3300 ICP   Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes
SX-200   Yes*  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
SX-2000   No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
5000/Axxess  Yes  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No
MiVoice Office 400  No  No  No  No  No  No  Yes  Yes  No  No  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes
MiVoice 5000  No  No  No  No  No  No  Yes  Yes  No  No  No  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes  Yes
MiVoice Connect  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  Yes  Yes  Yes  Yes  Yes  Yes
MiVoice MX-ONE  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  No  Yes


For Mitel 3300 ICP software compatibility by version, please refer to Knowledgebase Article 51183.

APPLIES TO

CCM 5.7 GA, 5.7 SP1, 5.8, 6.0, 7.0, 7.1, 8.0, 8.1, 9.0, 9.1, 9.2

Keywords: compatibility .NET Windows SQL IE internet explorer excel



Rate this Article:
     

Add Your Comments


Name: *
Email Address:
Web Address:
Verification Code:
*
 

Details
Last Modified:Monday, January 04, 2021
Last Modified By: montpetit.a
Type: INFO
Rated 4 stars based on 4 votes.
Article has been viewed 33,021 times.
Options