SalesForce 6.0 Cannot login agent. Error [CanGetAgent] Pkey not...

Expand / Collapse
 

SalesForce 6.0 Cannot login agent. Error [CanGetAgent] Pkey not found


Article ID: 51493 - Last Review: January 15, 2013

PROBLEM

A Sales Force agent is unable to log into the connector. 



SYMPTOMS

The Sales Force Connector shows error:  .NET [CanGetAgentPKey] Value cannot be null.  Parameter name: source||


Clearing of pfdscache and restarting Sales Force does not resolve issue.

CAUSE

At some point the Agent and Extension have been associated to different Employee entries (most likely via a Telephone System Synchronization). 



RESOLUTION

Reassociate the Agent and Extension to the same Employee.

1. Open YourSite Explorer
2. Go to Employee and find the secondary entry in the list (if created by a Telephone System Synchronization, the employee reporting number will match the extension reporting number)
3. Go to the Extensions tab and move the extension back to the Available members pane on the left with the arrow button.
4. Go to the correct Employee entry in the list
5. Select the extension in Available members and click the arrow to move it to Selected members on the right.



APPLIES TO

CCM 6.0 

Keywords: SalesForce Sales Force SFDC login log in



Rate this Article:
     

Add Your Comments


Name: *
Email Address:
Web Address:
Verification Code:
*
 

Details
Last Modified:Tuesday, January 15, 2013
Last Modified By: amontpetit
Type: FIX
Rated 1 star based on 1 vote
Article has been viewed 7,834 times.
Options