Ignite - Agent logout denied because Router thinks agent is...

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Ignite - Agent logout denied because Router thinks agent is currently in ACD, but real-time shows otherwise


Article ID: 51655 - Last Review: September 18th, 2012

PROBLEM

Agent logout is denied by the Router because it believes the agent is currently on an ACD call, while real-time shows them Logged in but not present. 



SYMPTOMS

The router log will show a number of duplicate callID entries, like the following:

39693 eError    3/28/2012 2:54:32 PM     Router::Call_CallOverflow, error for call 18de77e7-1e04-4ec8-ac73-fc3f281012b3       System.InvalidOperationException: Duplicate callID detected
45426 eError    3/28/2012 3:18:12 PM     Router::Call_CallOverflow, error for call 3657271f-f7bf-4545-83ca-644cadc5aecc       System.InvalidOperationException: Duplicate callID detected
45867 eError    3/28/2012 3:19:42 PM     Router::Call_CallOverflow, error for call 460d687a-c540-49ce-ac9f-56f801fde6c3       System.InvalidOperationException: Duplicate callID detected
47235 eError    3/28/2012 3:25:03 PM     Router::Call_CallOverflow, error for call cf6a6d9e-4d36-4c2b-9765-3c7b88e4ee0b       System.InvalidOperationException: Duplicate callID detected
 



CAUSE

The Router lost connection to the ACD stream and did not receive the IDLE event indicating an end to the ACD call.  This is most commonly caused by the Firewall on the Router being enabled.  Even after it is disabled the system does not recover on it's own.



WORKAROUND

Restarting the Router will clear the call states and start logging normally. 



APPLIES TO

5.10 SP1 

Keywords: logout denied ACD



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Details
Last Modified:Tuesday, September 18, 2012
Last Modified By: amontpetit
Type: FIX
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