Article ID: 51693 - Last Review: October 31st, 2012
PROBLEM
After upgrading to 6.0.1.0 and converting your Salesforce installation to a v4.0 call center, some agents are unable to log into their phones on the Salesforce Connector.
SYMPTOMS
An error is thrown by the salesforce connector (at the top left of the salesforce.com website) which looks like the following:
Error 500 stream:1:illegal character ref at '(\u0002) logging into Salesforce
CAUSE
The new salesforce connector attempts to cache a password in encrypted format, but can sometimes use a character that is not recognized by Salesforce.com
RESOLUTION
1. Download the attached KB89271.EXE hotfix to the Enterprise Server.
2. Double click the KB89271.EXE file and follow the on-screen prompts
3. Ensure that everyone logs out of salesforce.com, and the Salesforce connector is closed, then re-launch them. They will update from the server automatically.
NOTE: Applying this hotfix will shut down prairieFyre services for several minutes. It is recommended to apply this hotfix outside of business hours or during a scheduled maintenance to avoid service interruption.
APPLIES TO
SalesForce on CCM 6.0.1.0+
Keywords: Salesforce login error 500 stream illegal character