MCC Setup failed after move to a new domain

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MCC Setup failed after move to a new domain


Article ID: 51702 - Last Review: November 7th, 2012


PROBLEM

MCC Setup Failed due to Exchange Link being Down.

SYMPTOMS

After the MCC is moved from one domain to another, you get Exchange Link is Down. Agents will not be able to login to MCC nor will emails, chats, etc properly route. In the Exchange Objects log you will see an error similar to this:

Error 02/08/2012 16:22:36 Setting up the Exchange event sync for queue public folder file://./backofficestorage/caldemo.local/Public Folders/CyberAED/Queues/CCService/ failed with error Access is denied. Please ensure that this service runs under a valid Exchange Administrator account.

When checking the account that the Exchange service is running under, you will find that it is an Exchange admin.

CAUSE

By Default Exchange will not allow Public Folders to be administrated by anyone other than their initial creator.  The current Exchange admin belongs to the current domain, but the original folders were created by an admin on the old domain.  As such the current Exchange admin doesn't have the necessary privileges to modify the existing public folders.

RESOLUTION

Delete the CyberAED public folder in Exchange and restart the Exchange Setup service. This will recreate the folders with the correct permissions. Wait until the MCC Exchange Setup service recreates the public folders for the existing queues.  This will also bring the Exchange link back up.

APPLIES TO

MCC, all versions.

Keywords: MCC Exchange Link Down Exchange domain access denied



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Details
Last Modified:Wednesday, November 07, 2012
Last Modified By: amontpetit
Type: FIX
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