Enterprise Server upgrade or install fails with MSI error 1719

Expand / Collapse
 

Enterprise Server upgrade or install fails with MSI error 1719


Article ID: 51720 - Last Review: November 20, 2012

PROBLEM

An installation or upgrade fails with error 1719.  "Windows Installer service could not be accessed." 



CAUSE

This is a Windows MSI error.  Information can be found in the following Microsoft Knowledgebase articles:
For Windows 2003 or XP:  http://support.microsoft.com/kb/315346 
For Windows Vista or 7:  http://support.microsoft.com/kb/2642495



RESOLUTION

There are two solutions offered.  We prefer the following since it does not require any manual Registry edits.

  1. Click Start, click Run, type cmd in the Open box, and then click OK.
  2. Type cd %windir%\system32, and then press Enter.
  3. Type attrib -r -s -h dllcache, and then press Enter.
  4. Type ren msi.dll msi.old, and then press Enter.
  5. Type ren msiexec.exe msiexec.old, and then press Enter.
  6. Type ren msihnd.dll msihnd.old, and then press Enter.
  7. Type exit, and then press Enter.
  8. Click Start, and then click Turn off computer or Shut Down.
  9. Select the Restart option, and then click OK, or click Restart.
  10. Log on to the computer again.
  11. Download and install the latest version of the Windows Installer. For more information about how to obtain the Windows Installer, click the following article number to view the article in the Microsoft Knowledge Base:  893803 Windows Installer 3.1 v2 (3.1.4000.2435) is available
  12. Click Start, and then click Turn off computer or Shut Down.
  13. Select the Restart option, and then click OK, or click Restart.

 

APPLIES TO

CCM all versions 

Keywords: MSI error 1719 MSI Installer Service



Rate this Article:
     

Add Your Comments


Name: *
Email Address:
Web Address:
Verification Code:
*
 

Details
Last Modified:Tuesday, November 20, 2012
Last Modified By: amontpetit
Type: FIX
Rated 1 star based on 1 vote
Article has been viewed 6,822 times.
Options