Article ID: 51952 - Last Review: May 21, 2013
PROBLEM
A DNIS condition is being used to determine the route of calls. Calls are consistently routing down the failure branch, despite calls coming on matching DNIS.
SYMPTOMS
In the Port log you see the record containing the DNIS information received after the port has already finished processing the failure branch and routing.
CAUSE
This behavior can be caused by a very efficient callflow and a very powerful server. In this case it appeared to be processing the callflow faster than it could receive the records from the PBX.
RESOLUTION
In the callflow, add a 1 second delay activity between the Answer activity and DNIS Condition.
APPLIES TO
IVR 6.0 and newer
Keywords: DNIS condition failure branch callflow