Article ID: 52051 - Last Review: December 19, 2013
PROBLEM
During regular use, some clients experience intermittent crashes of the SalesForce Connector.
SYMPTOMS
You will see an error like the following in your Event Viewer:
Access Violation. at System.Runtime.InteropServices.CustomMarshalers.EnumeratorViewOfEnumVariant.MoveNext()
at
CTIAdapterSharpLib.CTIAppExchange.PopulateQueryResults(SF_MSApi4TypeLib.ISForceSession4,
SF_MSApi4TypeLib.IQueryResultSet4,
System.Collections.Generic.Dictionary`2<System.String,System.Collections.Generic.List`1<System.String>>,
System.Collections.Generic.List`1<CTIAdapterSharpLib.CTIRelatedObjectSet>,
Boolean) at
Mitel3300AdapterEngine.MitelAppExchangeSearchThread.ThreadSearch(SF_MSApi4TypeLib.ISForceSession4,
Mitel3300AdapterEngine.MitelSearchThreadInfo) at Mitel3300AdapterEngine.MitelAppExchangeSearchThread <>c__DisplayClass1.<Search>b__0()
CAUSE
This is a known issue with using For Each functions in COM objects.
RESOLUTION
We have added code to avoid For Each functions, in order to work around this COM limitation.
INSTALLATION INSTRUCTIONS
This Hotfix was included in our 6.0.2.3 release. If you have a specific business reason for being unable to upgrade, and still require this hotfix, please contact MiContact Center support.
APPLIES TO
6.0.2.2_Rev2
Keywords: 156465 kb156465 sfdc salesforce sales force salesforce.com intermittent intermittently crash crashing access violation