HowTo - Find a client computer that has an Extension in use

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HowTo - Find a client computer that has an Extension in use


Article ID: 52052 - Last Review: October 24, 2013

PROBLEM

If two computers have connected to the same extension in the Contact Center Client, they will fight for control of that extension. 



SYMPTOMS

In the Softphone/PhoneSet Manager toolbar you will see the controls grey out periodically as the other computer attempts to take control. 



CAUSE

This issue can occur if two computers are trying to control the same extension, or of the Contact Center Client did not shut down fully on one computer. 



RESOLUTION

First and foremost, ensure that you are exiting the Contact Center Client completely when you are finished with it.  This should ensure that the extension is released.

If you have encountered an extension that is being contested, you can resolve the issue simply by rebooting the computer that should have released it.  To find the computer in question:

1. On the Enterprise Server go to [InstallDir]\CCM\Logs\ and find the ConfigService - AuthenticationLogger.log file.
2. Open the log file in Notepad.
3. Go to the bottom of the log file and search upwards in the document for the agent's CCM Username (Control F will open the Find box).  You will find an entry that looks like the following:
    Info      10/24/2013 7:33:23 AM    prairieFyre.EnterpriseServices.Management.AuthenticationLogger 
    =========== LoginRequest Begin ===========
    Login type: User login 
    Username: jsmith
    Status: SUCCESS
    Identifier: uuid:USER/20006583W/ContactCenterClient/jsmith
    Version: 6.0.8093.0
    Duration : 00:00:02.6554444
    =========== LoginRequest End =============
4. In the Identifier field, the second component (20006583W in the example above) is the computer name where that login originated.  Search up again in the log file until you locate the previous login (with a different computer name).
5. Reboot the computer noted in the logfile where the Contact Center Client should not be active.
6. Your Extension should now be released and you can take full control from your current computer.



APPLIES TO

CCM 6.0 and newer 

Keywords: extension CCC ContactCenterClient Contact Center Client Softphone PSM PhoneSet Manager grey gray intermittent



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Details
Last Modified:Thursday, October 24, 2013
Last Modified By: andrew_montpetit
Type: HOWTO
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Article has been viewed 8,192 times.
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