Article ID: 52093 - Last Review: January 28, 2014
PROBLEM
After a new installation or upgrade the Routing Media service log shows a SQL error every few minutes.
SYMPTOMS
In the Routing Media service log you will see errors like the following:
Error: [date/time...] SqlException Error Index # 0 | Message: The object '0.8' does not exist in database 'CCMRouting' or is invalid for this operation.
As a consequence of this error, when any user logs out while an email is in their inbox, it will be moved to the Failed folder instead of requeueing.
CAUSE
The proc_DatabaseUsageMonitor stored procedure in the CCMRouting database did not run successfully during the install/upgrade.
RESOLUTION
The simplest solution is to restart the Routing Media service, which should attempt to re-run the stored procedure.
Alternately, you can manually run the stored procedure by going to [InstallDir]\CCM\Services\RoutingMediaService\ folder and double-clicking the proc_DatabaseUsageMonitor file. If an error occurs, the SQL Management Studio may give more detail as to the issue.
NOTE: You must have SQL Management Studio installed to run the store procedure.
APPLIES TO
7.0
Keywords: routing media service sql error object does not exist