Article ID: 52360 - Last Review: October 22, 2015
PROBLEM
Loading historical data in the Workforce Scheduling tool results in an error message
SYMPTOMS
When Launching WFS and running the forecasting tool when clicking 'Load Historical Data ' The following error appears in the WFS log file and the page does not load.
Error: 2015-Oct-07 12:15:35.136 A fatal error occurred, with the message: Could not load file or assembly 'Syncfusion.Grouping.Base, Version=11.3045.0.30, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89' or one of its dependencies. The system cannot find the file specified. ()
Fatal: 2015-Oct-07 12:15:37.635 Unhandled Exception
--- Start Exception Stack ---
System.IO.FileNotFoundException: Could not load file or assembly 'Syncfusion.Grouping.Base, Version=11.3045.0.30, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89' or one of its dependencies. The system cannot find the file specified.
File name: 'Syncfusion.Grouping.Base, Version=11.3045.0.30, Culture=neutral, PublicKeyToken=3d67ed1f87d44c89'
at prairieFyre.Forecasting.LoadHistoricalCallData..ctor(IForecastingServer forecastingServer)
at prairieFyre.Forecasting.CreateForecastingUI.LoadHistoricalData_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].
--- End Exception Stack ---
If you launch the forecasting tool directly from Contact Center Client, this function will work properly.
CAUSE
A pair of .DLL files needed are missing from the WFS folder, but present in the Contact Center Client.
RESOLUTION
You will need to copy two files.
1. Go to [InstallDir]\Applications\ContactCenterClient\.
2. Copy the syncfusion.grid.grouping.windows.dll and syncfusion.grouping.base.dll files.
3. Paste these files into [InstallDir]\Applications\CcsClient\.
4. Re-launch the WFS application.
APPLIES TO
MiCC Version 7.1.3.0
Keywords: WFS historical data forecasting error