CCMRunTimeServices database is frequently stopping and restarting...

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CCMRunTimeServices database is frequently stopping and restarting


Article ID: 52376 - Last Review: November 18, 2015

PROBLEM

The CCMRunTimeServices database is stopping and starting frequently throughout the day. 



SYMPTOMS

The Event Viewer has numerous entries reporting: Starting up Database 'CCMRunTimeServices'. 



CAUSE

By default SQL Express databases are created as AUTO_CLOSE ON. As such, they are closed as soon as the last session releases access to it. They will auto-open on next access. AUTO_CLOSE databases run an optimized recovery when opened so their opening, so this does not cause as large a performance impact as a fully fledged database open. 



RESOLUTION

You can disable the AUTO_CLOSE setting in order to stop these restarts and Event Viewer events.

1. Open SQL Management Studio and connect to your SQL instance.
2. Expand the menu on the left to expose the CCMRunTimServices database.
3. Right-click the CCMRunTimServices database and click Properties.
4. Select Options on the left.
5. In the Automatic section, find the Auto Close entry and set it to False.



APPLIES TO

MiContact Center Version 8.0 and newer 

Keywords: CCMRuntimeservices stopping starting restarting start event viewer auto_close



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Details
Last Modified:Thursday, November 19, 2015
Last Modified By: AndrewM
Type: FIX
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