IVR - After upgrade to MiCC 8.1 32bit ODBC connections no longer...

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IVR - After upgrade to MiCC 8.1 32bit ODBC connections no longer function


Article ID: 52522 - Last Review: , 2017

PROBLEM

After upgrade to 8.1 or later the 32 bit 3rd party Data Provider does not appear to function correctly.  



SYMPTOMS

  • IVR failures on database activities in callflows.
  • Missing Data Provider in Yoursite Explorer.

 



CAUSE

Configuration Manager service is now 64-bit. 64 bit SQL ODBC drivers from the 3rd party manufacturer are now required.  



RESOLUTION

Install 64 bit drivers. Use the ODBCAD32.EXE tool from the C:\Windows\System32 folder to configure the System Data Service Name (DSN).

NOTE: For ORACLE 11.2.0.1 there is a bug in the 64 bit version of that driver where .NET applications cannot read from Oracle 11.x

Use Oracle Instant Client Basic and ODBC 11.2.0.2 or later installations to obtain the proper driver or contact Oracle for support.

More information can be found here: https://blogs.msdn.microsoft.com/mariae/2012/07/05/arithmetic-operation-resulted-in-an-overflow-error-running-a-report-that-uses-a-connection-data-source-to-oracle-10/

 



APPLIES TO

MiCC 8.1 and newer 

Keywords: oracle ODBC 64 32 bit



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Details
Last Modified:Tuesday, January 31, 2017
Last Modified By: AndrewMontpetit
Type: FIX
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