Problem
Clicking the Build button in the Schedule Builder results in a fatal error: "Index was out of range. Must be non-negative and less than the size of the collection."

Symptoms
The error occurs in the Workforce Scheduling application when clicking the 'Build' button in the Schedule Builder. This error can be found in the CCSClient.log:
eError 8/9/2010 3:10:13 PM Unhandled Exception Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index | Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
at System.Windows.Forms.Control.MarshaledInvoke(Control caller, Delegate method, Object[] args, Boolean synchronous)
at System.Windows.Forms.Control.Invoke(Delegate method, Object[] args)
at System.Windows.Forms.Control.Invoke(Delegate method)
at prairieFyre.CCS.ScheduleBuilder.ScheduleBuilder.buildScheduleThread() in e:\TeamBuild\CCS\CI_CcsClient_5.7\Sources\Source\Applications\CcsClient\ScheduleBuilder\ScheduleBuilder.cs:line 142
at System.Threading.ThreadHelper.ThreadStart_Context(Object state)
at System.Threading.ExecutionContext.runTryCode(Object userData)
at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart()
Cause
There is a logic error in the Schedule Builder.
Workaround
Ensure you select all available Shift Types in the Schedule Builder dialog OR uncheck the "Optimize break distribution" option.
Resolution
This hotfix, along with all other CCM version 5.7 sp1 hotfixes created before January 2010, have been rolled up into one single hotfix.
The 5.7 sp1 Rollup of Hotfixes is available at the following link: KB41351
The original hotfix for this specific issue is no longer available and you must install the rollup.
Applies To
CCM version 5.7 SP1