Article ID: 50926 - Last Review: April 4, 2013
PROBLEM
The Contact Center Client Call Notes are not working.
SYMPTOMS
Inside the CCC, if you select the "display call notes" option in Phoneset Manager/Softphone, it does not display. The call notes window may display initially, but once it's closed it does not reopen.
The PFShell log contains the following error:
eError 13/08/2010 10:29:26 AM miniphoneview::Device_IncomingCall Can not activate the view CallAnnotationEditor.The original exception is: Controls created on one thread cannot be parented to a control on a different thread.
Parameter name: value at System.Windows.Forms.Form.set_MdiParentInternal(Form value) | at Microsoft.ApplicationBlocks.UIProcess.GraphNavigator.StartMDITask(TaskArgumentsHolder holder, TaskArgumentsHolder args)
at Microsoft.ApplicationBlocks.UIProcess.UIPManager.StartNavigationTask(String navGraph, TaskArgumentsHolder args)
at prairieFyre.WinForms.SoftPhone.SoftPhoneController.get_IsCallAnnotationsRunning() in e:\TeamBuild\CCS\CI_ContactCenterClient_5.7\Sources\Source\Applications\ContactCenterClient\PrairieFyreClientShell\Winforms\Softphone\SoftPhoneController.cs:line 408
at prairieFyre.WinForms.SoftPhone.MiniPhoneView.Device_IncomingCall(Object sender, CallReceivedEventArgs e) in e:\TeamBuild\CCS\CI_ContactCenterClient_5.7\Sources\Source\Applications\ContactCenterClient\PrairieFyreClientShell\Winforms\Softphone\MiniPhoneView.cs:line 4140
CAUSE
This is caused by attempting to access a control from a thread other than the GUI thread.
WORKAROUND
None.
RESOLUTION
This hotfix has been included in all subsequent software versions. For our latest software and updates, please go to www.mitel.com .
If you have a business need for this hotfix and are unable to update to a supported software version, please contact Customer Support for assistance.
APPLIES TO
CCM version 5.7 SP1
Keywords: 38819 call notes not displaying missing hidden unavailable does not open