Article ID: 50934 - Last Review: September 14, 2010
PROBLEM
Using the Mass Delete dialog to delete a portion of the Schedule results in deleting all Time Events in all Schedules. The deletion is not immediately evident. Closing and re-opening the Schedule or closing and re-opening the WFS application shows there are no more Time Events.
SYMPTOMS
If you have a WFS schedule for Monday to Friday and you do Mass Delete for Monday to Thursday, in the visual view it deletes only Monday to Thursday leaving Friday. However, it actually deletes the entire schedule from the database.
CAUSE
There is a logic error in one of the SQL stored procedures.
WORKAROUND
Restore the last nightly database backup. However, schedule changes made during the current day will be lost.
RESOLUTION
This hotfix, along with all other CCM version 5.7 sp1 hotfixes created before January 2010, have been rolled up into one single hotfix.
The 5.7 sp1 Rollup of Hotfixes is available at the following link: KB41351
The original hotfix for this specific issue is no longer available and you must install the rollup.
APPLIES TO
CCM version 5.7 SP1
Keywords: 39107