Article ID: 50937 - Last Review: September 14, 2010
PROBLEM
Workforce Scheduling breaks that are configured to be less than 15 minutes long are not scheduled correctly.
SYMPTOMS
Breaks configured to be 5 or 10 minutes long cannot be scheduled to their configured length when "Smallest Scheduling Interval" in User Preference is set to 15 minutes or greater. When drop inserting the break onto an already scheduled shift, the scheduled break ends up having a duration of 15 minutes. Also, when scheduling the break with Schedule Builder, no breaks of this type are scheduled.
CAUSE
This is caused by a logic error in the code.
WORKAROUND
In user preferences, change the drop down value for "Smallest Scheduling Interval" to 5 minutes. This will allow you to insert breaks of the correct duration.

OR
If using a Fixed Shift type, configure and associate a Fixed Break of duration 5 or 10 minutes to the Fixed Shift type and Drop Insert this shift. However, there is no workaround for the inability to schedule 5 and 10 minute breaks in Schedule Builder.
RESOLUTION
This hotfix, along with all other CCM version 5.7 sp1 hotfixes created before January 2010, have been rolled up into one single hotfix.
The 5.7 sp1 Rollup of Hotfixes is available at the following link: KB41351
The original hotfix for this specific issue is no longer available and you must install the rollup.
APPLIES TO
CCM version 5.7 SP1
Keywords: 39081 WFS breaks