Article ID: 50981 - Last Review: April 4, 2013
PROBLEM
You receive an error when setting a Contact Center Client alarm in a second Queue by Period monitor.
SYMPTOMS
Steps to reproduce:
• Open up contact center client with a blank profile
• Click on 'Period' and choose any queue
• Right click on the monitor, and set alarms
• Click on 'Offered' and then 'Add threshold' with value '5'
• Click OK to apply changes
• Click on 'Period' and choose any different queue
• Right click on the second period monitor and click 'Set Alarm' and the following Unhandled exception will occur:

The PFShell log contains the following error:
eError 10/13/2010 1:07:12 PM Unhandled exception occured | Contact Center Client [Unhandled Exception]
Index was outside the bounds of the array., PrairieFyreClientShell
at prairieFyre.WinForms.Monitors.Monitor_QueueByPeriod.AlarmItem_Click(Object sender, EventArgs e) in e:\TeamBuild\CCS\CI_ContactCenterClient_5.7\Sources\Source\Applications\ContactCenterClient\PrairieFyreClientShell\Winforms\Monitors\Monitor_QueueByPeriod.cs:line 2286
CAUSE
There is a fault in the device selection code in the Set Alarm dialog for Queue by Period real time monitor.
WORKAROUND
None.
RESOLUTION
This hotfix has been included in all subsequent software versions. For our latest software and updates, please go to www.mitel.com .
If you have a business need for this hotfix and are unable to update to a supported software version, please contact Customer Support for assistance.
APPLIES TO
CCM version 5.7 SP1
Keywords: 39980