Article ID: 51460 - Last Review: , April 10th, 2012
PROBLEM
Unable to remove last agent from agent group while calls are in queue
SYMPTOMS
Attempting to remove agent from group using AGP results in an error like:
Error 3/20/2012 11:28:16 AM MitaiCommand RedirectCallCommand on MitaiQueueDevice 1-7000, CallID 750, Destination DN 506 - Execute Failed with return code SXERR_INVALID_DN
The ContactCenterCLient.log will show errors such as:
Error 4/4/2012 8:47:32 AM DeviceControl Originating message, DeviceCtrlMsg, DevicePkey: 71ed6a61-249b-4022-85f2-6803ec9fa326, Extn: , Code: , ActionType AgentLeaveGroup returned code SXERR_CALLS_QUEUED
Error 4/4/2012 8:47:32 AM Device control failed - Return code: SXERR_CALLS_QUEUED; Orgininating message: DeviceCtrlMsg, DevicePkey: 71ed6a61-249b-4022-85f2-6803ec9fa326, Extn: , Code: , ActionType AgentLeaveGroup
Error 4/4/2012 8:47:32 AM Device control failed - Return code: SXERR_CALLS_QUEUED; Orgininating message: DeviceCtrlMsg, DevicePkey: 71ed6a61-249b-4022-85f2-6803ec9fa326, Extn: , Code: , ActionType AgentLeaveGroup
CAUSE
MCD 5.0 does not allow the last agent in a queue to remove presence while there are still calls in queue. There is an Auto logout last agent setting on the PBX but it does not appear to change this behavior in relation to AGP. This is an intended feature of the PBX software, as such we do not expect a change at present.
WORKAROND
The only workaround for this is to ensure that the queue is clear before removing presence on the last agent.
APPLIES TO
MCD 5.0
Keywords: Invoker DN MCD AGP