Article ID: 51642 - Last Review: March 22, 2013
PROBLEM
There is a known issue where the Updater Service stops and starts roughly every 5 minutes on remote servers.
SYMPTOMS
1. Updater runs
2. Updater tries to update itself. This gets handled in a new process
3. Updater tries to update IVR Inbound (stops it, tries to update, FAILS on a file delete, starts it again)
4. The new process stops the updater.
5. The new process updates the updater files
6. The new process FAILS upon trying to delete a file
7. The new process starts the updater again
8. Start over with step 1.
CAUSE
This issue occurs when the remote server is installed to a non-default location. There is an error in the file delete action that is associated with both these updates.
WORKAROUND
1. On the Enterprise Server, go to the [InstallDir]\CCM\Websites\CCMWeb\Applications\ folder.
2. Open the UpdaterServiceManifest.xml file.
3. Change the <location> node in the manifest file to [InstallDir]\Services\UpdaterService\ and save the file.
It will look like: <location>C:\Program Files (x86)\prairieFyre Software Inc\CCM\Services\UpdaterService\</location>
4. Open the IvrInboundManifest.xml file located in the same folder.
5. Change the <location> node in the manifest file to [InstallDir].
It will look like: <location>C:\Program Files (x86)\prairieFyre Software Inc\CCM\</location>
6. Update the FileDeleteProcessor1 setting from
<task type="Microsoft.ApplicationBlocks.Updater.ActivationProcessors.FileDeleteProcessor, Microsoft.ApplicationBlocks.Updater.ActivationProcessors, Version=2.0.0.0, Culture=neutral, PublicKeyToken=null" name="FileDeleteProcessor1" path="..\..\Ivr\Media\filesync.id" />
Or
<task type="Microsoft.ApplicationBlocks.Updater.ActivationProcessors.FileDeleteProcessor, Microsoft.ApplicationBlocks.Updater.ActivationProcessors, Version=2.0.0.0, Culture=neutral, PublicKeyToken=null" name="FileDeleteProcessor1" path="Ivr\Media\filesync.id" />
To
<task type="Microsoft.ApplicationBlocks.Updater.ActivationProcessors.FileDeleteProcessor, Microsoft.ApplicationBlocks.Updater.ActivationProcessors, Version=2.0.0.0, Culture=neutral, PublicKeyToken=null" name="FileDeleteProcessor1" path="[InstallDir]\Ivr\Media\filesync.id" />
7. Update the FileDeleteProcessor2 setting from
<task type="Microsoft.ApplicationBlocks.Updater.ActivationProcessors.FileDeleteProcessor, Microsoft.ApplicationBlocks.Updater.ActivationProcessors, Version=2.0.0.0, Culture=neutral, PublicKeyToken=null" name="FileDeleteProcessor2" path="..\..\Ivr\Workflow\filesync.id" />
Or
<task type="Microsoft.ApplicationBlocks.Updater.ActivationProcessors.FileDeleteProcessor, Microsoft.ApplicationBlocks.Updater.ActivationProcessors, Version=2.0.0.0, Culture=neutral, PublicKeyToken=null" name="FileDeleteProcessor1" path="Ivr\Workflow\filesync.id" />
To
<task type="Microsoft.ApplicationBlocks.Updater.ActivationProcessors.FileDeleteProcessor, Microsoft.ApplicationBlocks.Updater.ActivationProcessors, Version=2.0.0.0, Culture=neutral, PublicKeyToken=null" name="FileDeleteProcessor1" path="[InstallDir]\Ivr\Workflow\filesync.id" />
8. Save the file.
9. Wait for 5 minutes for the updater cycle to begin again.
RESOLUTION
This issue is expected to be resolved in 6.0.2.2
APPLIES TO
6.0 SP1
Keywords: updater service restarting stop start